AudioBox 1818VSL, 44VSL and 22VSL
22 postsPage 2 of 2
1, 2
I'm not sure what you mean when you say "rolling back is not an option". If you mean using 1.3 instead of latest UC driver, 1.3 is not "rolling back" but is the last approved working version that included VSL console.It is working here for me on latest Win 10.

Did you do the full install first as recommended?

http://www.presonus.com/support
Windows 10 X 64 : AMD Phenom II X 4 945
ATI Radeon 5450 / 512 RAM
8GB RAM/1T SATA 7200 RPM
iPad2
Assorted PreSonus Interfaces and Gear


To add your software and hardware specs to your signature to make it easier for us to help you, click HERE.
Answers at http://answers.presonus.com/
User avatar
by kondzio on Sat Jun 17, 2017 9:08 am
I meant about Windows rolling back to previous release not the driver.
The issue is that i can't install 1.3 driver. I've just installed a fresh copy of windows (ver. 1703 build 15063.413 - it's Creators update) (I needed format c anyway) and after plugging in my audiobox 22vsl it clicks and pops (like it couldn't initialise). Then when I tried to install 1.3 driver i got an error. Tried that multiple times but failed. The only thing that works is Universal Control (but still the device clicks and pops when trying to play sound etc.), but i need that VSL console :)
I've also tried uninstalling UC (completely) with 3rd party uninstaller, but it didn't help and still cannot install 1.3 version :/
Sooner or later Microsoft will force us to get this Windows update, that's why i don't want to roll back to previous release
Any ideas?

error code and screen:
Image

[EDIT]
After hours of struggle I managed somehow to install v 1.2.2 driver and it seems to be working fine for now.

22 postsPage 2 of 2
1, 2

Who is online

Users browsing this forum: No registered users and 3 guests