1 post
Page 1 of 1
Hello. It's my first post here.

I've been using a Firestudio Project for 2 years now and never had problems. I was using it on a Intel i7 2700, Windows 10 Pro 64 Bits

A month ago I decided to upgrade my PC and built a Ryzen 7 2700, Gigabyte AB350 Gaming 3 motherboard and a AMD RX 580 Gpu.

Thing is. Firestudio won't sync anymore in this PC. I have 2 scenarious.

The first one is that I connect the interface and windows instantly crashes making me reboot.
The second one is that it doesn't crash, syncs for about 10 seconds and then goes out of sync.

I tried contacting Presonus support but it's just useless. All they do is tell me to just use another firewire cable and very basic stuff that I already tried.

I did a full reinstall of universal control, following the guide to fully uninstall. And tried every version available to download (1.7.2 up to 1.7.6) And none of them works.

Concerning to my Firewire card. I don't know the name right now but it's the same that i've been using forever. So it does work. Besides, I tested both the interface and the firewire card on other 2 separate pcs (both Intels, I7 2nd gen and I5 4th gen, Windows 10 64 Bits Pro up to date) and everything works perfectly, no problem at all.

Which makes me think, is there an uncompatibility issue with some of AMD hardware that i'm not aware?

I just don't know what to do anymore. I'll probably have to sell the interface and get a new one. But if there is a solution to this problem I'll gladly try it.

Thanks in advance.

1 post
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest