9 posts
Page 1 of 1
Hi. I was shocked that I figured out a way to get my Firestudio Project working on a Windows 11 machine and wanted to post how I did it in case it helps anyone.

I had started looking into upgrading from Windows 10 to 11 before I realized that Presonus had posted that it would not support the FireStudio Project on Win 11.

To make my system compatible with Win 11, I had to convert my hard drive partition from MBR to GPT, but once I successfully did this I noticed that the FireStudio Project has stopped connecting. That's when I looked up the support info and saw that support was stopping with 10. I had already downloaded the Win 11 update, but not installed it, but suppose something in windows might have updated in preparation and caused it to stop working. I paused all windows updates, and started working with Presonus Tech support. They were very attentive and suggested several things, but nothing seemed to work, and they suggested that I might need to reinstall WIn 10 or earlier.

I thought I'd go ahead and try 11, and then decide if I might go back and reinstall 10 or just start shopping for a new interface. After completing all the Win 11 updates the Studio Fire was acting strangely. I say it connect at one point but would not play audio. I decided to play around with drivers. I already had the legacy driver installed (PreSonus_Universal_Control_Installer-5884.exe), but I thought what the heck, what if I install the latest PreSonus_UniversalControl_v3_6_4_87069.exe? And it worked! Somehow with both running I can now use the old Universal control interface in Windows 11, and so far everything seems to function correctly!
User avatar
by karolkurtyka on Wed Nov 16, 2022 2:07 pm
Hello, that sounds great. What motherborard/soundcard do u use ? Thinking of getting myself a new firewire card as new pc does not have legacy PCI port sadly. Would love to get my firestudio back to work... moved to ssl2+ usb but missing my trusty piece of presonus junk ; )
User avatar
by benshirley on Mon Nov 28, 2022 10:37 pm
I did wonder if my particular firewire card might have something to do with it working. I think I'd have to pull the card to remember what it is specifically, but the windows device manager says it's a "Texas Instruments 1394 OHCI Compliant Host Controller" if that is any help.
Edit: I just pulled my card and am pretty sure it's this one:
https://smile.amazon.com/gp/product/B00 ... 1MTF&psc=1

My motherboard is a ASUS B450M Prime-A CSM so besides the Presonus FireStudio Project, I"m using the onboard sound card on the motherboard.
User avatar
by keno1215 on Sat Dec 03, 2022 3:29 pm
hi thanks for this post! Im trying to set up my Firestudio projects as well. I had just loaded that newer driver and I get a blue light now and looks good in device manager. But when I try to record in Cubase 12 it says my ASIO driver isnt running. Curious if you have bumped into the same?

Also Im unable to get windows to recognize my the 2nd Firestudio when I daisy chain them like I used to do with Win7. Do you have more than one running? Thanks!
User avatar
by benshirley on Mon Dec 05, 2022 8:21 am

I assume you already had the old legacy driver installed? If so you might try removing all the drivers and start back with the legacy driver, and then add the UniversalControl_v3_6_4_87069.

My DAW is Mixcraft so not sure if that might make a difference vs Cuebase.

The only other thing I can think of is I've been having good results using the ASIO4all virtual driver to get less buggy audio, less disconnects when the system goes to sleep, at lower latency. You might install that and try it with the presonus to see if it might just start working.

Oops almost forgot, I've just got 1 firestudio, I've never tried daisy chaining.

Good luck.
User avatar
by keno1215 on Thu Dec 08, 2022 6:50 pm
hi Ben. No luck at all. I have now done a clean install back to win 10 and I still cant get the Firestudio Projects to synch. opened a case with Presonus and they wont help saying now that even win 10 is not supported. Sucks i cant record anymore. Were yoiu able to get yours to synch with win10 as well? any help you can offer is so greatly appreciated!

best regards,

User avatar
by benshirley on Fri Dec 09, 2022 9:49 am
Hi. Aw man, sorry it's not working even on win 10. That's definitely shady that they are now saying no support in windows 10. I for one will not buy my next interface from Presonus for the reasons of historically buggy drivers and revoking support for firewire prematurely. I had seen some things on the web about windows stopping support at different points for firewire, like at windows 10 specifically, but they seem unconfirmed and it always worked for me. Maybe there are just too many conflicts between hardware and software now that it can't be guaranteed. Still if you had your interface working on win 10 previously you should be able to get it working again with the same hardware. Are you using the legacy presonus drivers? PreSonus_Universal_Control_Installer-5884.exe is the file that worked for me. Last time I looked at their site I couldn't find it. Maybe that's part of their support rollback? I can send you a copy if you'd need it.
User avatar
by drummer10125 on Fri Feb 03, 2023 3:19 am
I am using my 2 FireStudio Project interfaces on Windows 10 with Universal Control version 1.7.2. Try this driver first. If this driver does work play around with the other older drivers until something works or the version 3.x.x drivers. Hopefully you all find one that works.
User avatar
by carlpanco on Thu Feb 23, 2023 12:25 pm
Funny enough I have the 1824c and it doesn't work worth a poop and my unsupported Firestudio Project works swimmingly.

9 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest