3 posts
Page 1 of 1

My firestudio mobile has a weird hardware problem. When I turn my headphone volume past 9 o'clock the volume works normally. When I turn it down the right side stays louder. Actually it doesn't get any quieter; sound comes through even if the headphone volume is turned all the way down. Roughly speaking the volume stays the same on the right side during first 10-12 clicks while works properly on the left side.

I know the problem isn't in the Universal Control, I have proper settings there (and am actually turning volume down over there to get more usable range in my headphones).

I'm also fairly certain the headphone volume potentiometer is not the issue either; I opened up the thing, desoldered both the Phones and Main pot (they use the same 10k log value) and switched them over (I'm not using any monitors at the moment so I'm not too worried about that right now). No change.

Any ideas? It's hard for me to look for solution since I can't find the schematics.
User avatar
by mrpicki on Wed Aug 30, 2017 12:47 am
Hi there,
Did you ever find a solution to this issue?
I'm having the exact same problem.
User avatar
by Anselmi71 on Sat Sep 16, 2017 12:21 pm
I had the same problem with my previous firestudio mobile. I think there is no solution to this. I have bought the second unit which this problem is not so audible but still there is minor volume difference between L/R channels.

3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests