Page 1 of 1

midi file sounds wrong after importing and saving

Posted: Sun Jul 28, 2019 9:00 pm
by peterwu2
I dropped a midi file into studio one prime. It plays but sounds slightly different.
Without doing any editing, I then save the file as midi. When I play the saved midi file in windows, it sounds very different as if some percussion instruments is turned into pianos.

I attached the original midi file, and the midi file that has been saved.

What's going on? How can I make this work?

windows 8.1
studio one prime 4.5.2.53232 win x64 (built Jul 9 2019)

Re: midi file sounds wrong after importing and saving

Posted: Wed Jul 31, 2019 1:12 pm
by scottyo7
I don't know everything and may not understand you here but...
Won't it sound different based upon which instrument set you've selected on the track where the midi file was dropped?

I'm not sure which 'default' instrument set S1 uses but if you select a B3 or a Violin (for example, in Presence XT) the midi notes follow that instrument don't they?

Re: midi file sounds wrong after importing and saving

Posted: Thu Aug 15, 2019 4:26 am
by Lawrence
I then save the file as midi. When I play the saved midi file in windows, it sounds very different as if some percussion instruments is turned into pianos.


Studio One doesn't make Standard MIDI files for the web or whatever as it doesn't export program changes. Your Windows synth isn't assigning the correct sounds to the tracks because there's no program changes in the file.

If you need to make SMF's that use GM patches you'll have to use another sequencer.