This forum is for Tips and Tricks. Please do not post any questions in this forum. It is only for information.
3 posts
Page 1 of 1
Here's a great video by Johnny Geib on implementation of Control Link.

https://www.youtube.com/watch?v=MG76UEQqcuI

http://www.presonus.com/support
Windows 10 X 64 : AMD Phenom II X 4 945
ATI Radeon 5450 / 512 RAM
8GB RAM / 1T SATA

Mac Mini (Late 2014)

Faderport and Faderport 8
Yamaha S-08
Fishman TriplePlay
Logidy Controller

Assorted PreSonus Gear

To add your software and hardware specs to your signature to make it easier for us to help you, click HERE.
Answers at http://answers.presonus.com/
User avatar
by Mac Money on Mon Jun 26, 2017 4:25 pm
Thank You this really got me up and running with my BCR2000

George Ware
StudioOne v4.0.1 Pro 64bit
Pro-Tools 12.5 64bit
Waves DigiGrid IOS
PreSonus CS18ai & BCR2000 Control Surface
Intel 6 Core i7 3.2Ghz.
Windows 10 Professional 64bit. v1803
Arturia KeyLab-61
URS, Waves Mercury+Studio Classics, EMI, Sonnox Oxford, Antares, Plugin Alliance, Nomad Factory,TL Labs, Serato, Massey, Komplete Ultimate 11, Arturia V-Collection 6, Lounge Lizard 4, Korg Collection, UVI Falcon, P&M VIP, Audio Damage, Melodyne Studio, VocAlign, Eventide, IL Vocodex, IL GrossBeat, Artillery 2, OPX, Softube and IKM Total Studio Max.
As of 23 May 18
User avatar
by TheTwangmeister on Thu Jan 04, 2018 12:37 pm
Hi Jonny

I watched your video because I couldn't get this to work with my Mackie Control C4. As you probably will know the BCR 2000 is Behringer's version of the Mackie C4.

I have just moved over from SONAR which I have used for 20 years. The C4 worked perfectly there. For some reason it isn't in the list of recognised devices in Studio One even though the Mackie Control and the Extender are.

Here is the problem I had after attempting to set the C4 up as a generic Control Link controller, and after following your steps thoroughly I still have exactly the same problem.

1. I do not get the visual feedback on my C4 knobs, it's like there is just one way communication. But even worse...
2. The knobs do not respond properly. Namely, the parameter value jumps from around zero to around 50 even though these are continuous control knobs just like yours on the BCR2000.

Once I have set up my 32 knobs with the Midi Learn and ticked the Transmit Value option, then this is what happens. When I turn a C4 knob clockwise the parameter value jumps to 0.79. When I turn a knob anti-clockwise it jumps to 51.18. This renders the buttons absolutely useless. And of course I get nothing on my visual displays on the C4. What am I doing wrong? Why does this not work?

Also, why do you set it up as a keyboard rather than a Control Surface? I have to say it makes no difference which option I go for, the result is the same.

Help please!!!

SONAR Refugee
Studio One 3 Pro
SONAR Platinum
Windows 10 Pro 64, Intel Quad Core i7 6700k, 16GB Ram
Apollo Firewire, Focusrite OctoPre
UAD octo dsp (Apollo quad and PCIe quad)
Mackie Control and 2 Extenders
Mackie Control C4 (unusable in Studio One) :(

3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests