10 posts
Page 1 of 1
I installed SampleTank 3 in my 64 bit vstplugins folder, but S1 does not show it in instruments list even after refresh. Most of my plugins are dll files, but ST3 is a .vst3 file.
Do I need to put it in a special VST3 folder on Windows for it to be recognized by S1?

win 8.1 64 bit
3.4 ghz 32 gb ram
Motif 8
Roland Quad-Capture
Studio One 3 Professional (latest version 3 update)
User avatar
by whitePhazer on Fri Jul 25, 2014 5:52 am
Does S1 know where to look?

Win 7 64bit
Studio One Professional x64 (always latest update)
Intel i5 3.30GHz overclocked @ 4.20 GHz
Azus deluxe Motherboard
8GB RAM
M-AUDIO - Audiophile 192
M-Audio Oxygen 49
Akai MPD26
American Fender Stratocaster Deluxe
Retired, plenty of spare time
User avatar
by Thomas on Fri Jul 25, 2014 6:53 am
Musical Gym wroteI installed SampleTank 3 in my 64 bit vstplugins folder, but S1 does not show it in instruments list even after refresh. Most of my plugins are dll files, but ST3 is a .vst3 file.
Do I need to put it in a special VST3 folder on Windows for it to be recognized by S1?


The VST3 folder in Windows is always this location:
C:\Program Files\Common Files\VST3

This must not be altered as this is the location VST3s are loaded form.

Normally all VST3 installers install to this location.

For VST2s its a different story.

Thomas Mansfeld

Product Specialist / PreSonus Software Ltd
User avatar
by Musical Gym on Fri Jul 25, 2014 2:04 pm
Thanks guys. Yes, S1 knows the location and I also put it in the default location for VST3s.

I found out that the dll provided works in 64 bit, so I'm up and running now.

I think maybe S1 doesn't support VST3 yet.

win 8.1 64 bit
3.4 ghz 32 gb ram
Motif 8
Roland Quad-Capture
Studio One 3 Professional (latest version 3 update)
User avatar
by whitePhazer on Fri Jul 25, 2014 2:34 pm
I don't think all versions do. Put your specs in your signature and it'll allow people to help you quicker.

Win 7 64bit
Studio One Professional x64 (always latest update)
Intel i5 3.30GHz overclocked @ 4.20 GHz
Azus deluxe Motherboard
8GB RAM
M-AUDIO - Audiophile 192
M-Audio Oxygen 49
Akai MPD26
American Fender Stratocaster Deluxe
Retired, plenty of spare time
User avatar
by Musical Gym on Fri Jul 25, 2014 2:55 pm
Thanks, it showed up in the browser in the VST3 folder under a sub-folder called Sampler.
Interesting since I don't have a folder named sampler under C:\Program Files\Common Files\VST3.

At least now I can access the dll and vst3 plugs from latest S1 Pro 64 bit.

win 8.1 64 bit
3.4 ghz 32 gb ram
Motif 8
Roland Quad-Capture
Studio One 3 Professional (latest version 3 update)
User avatar
by Kahlbert on Sat Aug 02, 2014 3:23 pm
Musical Gym wroteThanks, it showed up in the browser in the VST3 folder under a sub-folder called Sampler.
Interesting since I don't have a folder named sampler under C:\Program Files\Common Files\VST3.

At least now I can access the dll and vst3 plugs from latest S1 Pro 64 bit.

That's funny. Probably IK has created that "Sampler" category (since it's read from the plugin itself AFAIK). I use the "Flat" tab in the instrument browser to have all my instruments in a list without subfolders (then again, I don't have dozens of them) ...

Dolphin Blue - Songs of Tom Waits
--------------------------------------------
Dropbox - Free Online Storage
(Use this link to get us both even more free space.)
User avatar
by Lequarius on Mon May 04, 2015 9:57 pm
Hi,

This is the closest thread I have been able to find with regards to getting VST3's to work.

I have about 100 VST3 effects that I would like to have on S1 but they are not recognized.

Some are seen, while others are completely missed. They were all supposed to be 64 bit effects, but don't know how to confirm that. I'm not even sure I understand the difference between a VST2 and VST3 effect. (I'll look into the difference). I'm at work and decided to post this from my iPad.

Hopefully I can get some direction as to where to go by the time I get home.

Thanks,

Lequarius

Athena 3U Chassis - i7-3770K Processor 5.0GHz(OC) | Gigabyte Z77X-UD3H | 2 X 4GB Patriot Viper Extreme DDR3-1600 Modules | 1TB Seagate Barracuda HDD | 2 X SanDisk Extreme Pro 240GB SSD | SIIG 3 Port 9 wire Firewire PCIe Card | VIA 3 Port USB 2.0 Card | LG DVD/CD Drive | Gigabyte GTX 750 1GB GDDR5 4 Monitor Card | S1 Pro 3 | D-Link DIR-615 router | Edirol UA-700 | AB1818VSL | AS-900T IE Monitor System | 2 X ACER 21.5" LCD Monitors | 2 X 48" Samsung LED TV's (Control Room) | Presounus 24.4.2 AI Mixer | Alesis SR18 | Digitech Vocalist Live Pro | Behringer DSP2024P
User avatar
by matthewgorman on Tue May 05, 2015 10:35 am
Make sure first of all that VST3 service is enabled from the advanced tab in preferences. Then confirm that the VST is 32 or 64 bit. You can install the 32 bit version on the same machine with the same activation.

On Mac the 32/64 are the same installer. Clicking info for the shortcut presents a checkbox to run as 32 bit. 64 is the default.

Matt

Lenovo ThinkServer TS140 Win 10 64bit, 8GB RAM, Intel Xeon
Lenovo Thinkpad E520, Windows 7 64bit, 8 GB RAM, Intel i5 Processor
StarTech EC13942 34mm Expresscard
S1Pro V2 , Melodyne Studio 4, Nomad Factory Studio Bundle, Waves , RM16, Studio 192, DP88, Faderport, Central Station Plus, Yamaha HS50 Monitors, Sceptre 6-8 Monitors, Temblor 10.
User avatar
by Lequarius on Tue May 12, 2015 8:02 am
Thanks Matt, you hit it on the nose. The ones I were seeing were the VST2 versions because as soon as I enabled the service I got all my effects and the ones I was seeing were duplicated.

So again. Thanks

Athena 3U Chassis - i7-3770K Processor 5.0GHz(OC) | Gigabyte Z77X-UD3H | 2 X 4GB Patriot Viper Extreme DDR3-1600 Modules | 1TB Seagate Barracuda HDD | 2 X SanDisk Extreme Pro 240GB SSD | SIIG 3 Port 9 wire Firewire PCIe Card | VIA 3 Port USB 2.0 Card | LG DVD/CD Drive | Gigabyte GTX 750 1GB GDDR5 4 Monitor Card | S1 Pro 3 | D-Link DIR-615 router | Edirol UA-700 | AB1818VSL | AS-900T IE Monitor System | 2 X ACER 21.5" LCD Monitors | 2 X 48" Samsung LED TV's (Control Room) | Presounus 24.4.2 AI Mixer | Alesis SR18 | Digitech Vocalist Live Pro | Behringer DSP2024P

10 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 12 guests