18 posts
Page 1 of 1
I have that trouble... snap to grid not working on AUDIO events in one project...When I create a new project-it work again.. I load a old project-not working.. I try to reenable all options (snap to grid-relative grid and other options-not working...
midi events work fine
User avatar
by jpettit on Tue Jan 13, 2015 9:46 am
Do you see the snap icon blue in that project?
There are also different settings for snap in the editor versus the arranger window.

Just to be clear snap is a grid tool so it should be working the same and audio as in MIDI.

Perhaps explain more of what your expectations are.

My Website, Free Studio One Advance Training
SPECS:Win 10 64-bit, 12 Core i7: 32Gb DDR4 ram, 40" 4K monitor, StudioLive 24, Quantum, Faderport16, Central Station Plus, Sceptre 6,Temblor T10, Eris 4.5, HP60, Studio One Pro 4.0, Reaper 5.9, Sonar Platinum
User avatar
by sergeykuptsov on Wed Jan 14, 2015 3:54 pm
Yes,, snap is blue.. now it working again.. I did nothing with it, but now it working
User avatar
by TheFarm on Sun Sep 20, 2015 11:58 am
I was able to snap to the grid last night in the arranger, now I cannot this morning. No settings were changed.

I can snap in the editor, though I see no difference between the two "Snap" selections. The editor "Snap" is not blue, yet it snaps, when my arranger does not.
User avatar
by robertvenneri on Mon Sep 21, 2015 12:51 pm
I have noticed intermittent snap failure as well . Then it just seems to fix itself. Im a pretty persistant troubleshooter so if I manage to find the trigger ill definately post. . You are not alone!

Windows 8.1 - Studio One 3 Professional - Intel Core i5-4690K Devil's Canyon Quad-Core 3.5GHz - ASUS Z97-E LGA 1150 Intel Z97 - 8GB (2 x 4GB) DDR3 SDRAM - SAMSUNG 840 EVO - On board video (for now) - Focusrite 18i20 interface - KRK Monitors - Glyph Studio External drive (amazing drive!) - Razer NAGA mouse - AXIOM49 midi controller - Alesis DM10 drum kit
User avatar
by robertvenneri on Wed Sep 30, 2015 9:00 pm
any update on this? i hav ebeen noticing it more lately, ill be writing a song and bam, the snap stops working. It is still engaged, and nothing else has changed. I think it comes back to the arranger track like most of my problems seem to but i cant confirm this.

Windows 8.1 - Studio One 3 Professional - Intel Core i5-4690K Devil's Canyon Quad-Core 3.5GHz - ASUS Z97-E LGA 1150 Intel Z97 - 8GB (2 x 4GB) DDR3 SDRAM - SAMSUNG 840 EVO - On board video (for now) - Focusrite 18i20 interface - KRK Monitors - Glyph Studio External drive (amazing drive!) - Razer NAGA mouse - AXIOM49 midi controller - Alesis DM10 drum kit
User avatar
by alpatemrah on Wed Oct 07, 2015 9:51 pm
Same here
Snap not working on one project
I tried renaming, saving to a new folder etc.

Doesnt work and hasnt been "intermittent" . Just stopped working for one project.
I did the october 5th update but no fix.
User avatar
by johnbliss on Mon Nov 23, 2015 7:15 pm
solved
go to the snap menu...... click on the adaptive down arrow....make sure :snap to grid is selected:

windows 10 64 bit i7 32 gig RAM
ssd samsung c drive
raid 2 data drive 4 TB
presonus studiolive 16
studio one 4
notion
User avatar
by bamboozle on Wed Nov 25, 2015 3:40 pm
Conveniently got this bug on project day before deadline. Oh the joy :+1

S1-3 i5 320 6gb ram win10+7 (dualboot)
Motu Avb
Ipad air (for s1 remote and motu avb)
Komplete 10 ultimate
Fabfilter pro-q2 Pro-mb Pro c-2 Pro-l Saturn
Serum, SynthMaster, Diversion, DCAM synth squad+strobe 2
Maschine2, MPC Studio

P.s. i moan alot
User avatar
by niles on Wed Nov 25, 2015 4:45 pm
Are you sure you guys aren't fighting the Adaptive feature which changes the snap behavior based on the current zoom level.
In other words: The more you zoom in, the finer the snap resolution is.

OS: Windows 10 Pro | HW: P9X79 • i7 3930K • 16GB • 3x EVO 860 • NVIDIA GT1030 (@WQHD) • RME AIO
User avatar
by bboerma on Fri Nov 27, 2015 5:34 am
niles wroteAre you sure you guys aren't fighting the Adaptive feature which changes the snap behavior based on the current zoom level.
In other words: The more you zoom in, the finer the snap resolution is.


Niles, you made my day! Thanks alot, that did the trick.

Home Studio Connection
---------------------------------------------------------------------------------------------
Studio One 3.5 Pro - Win 10 X64 ( i7 6700k, 16 GB Dual 2400) - Focusrite 6i6
Focal Alpha 50 - Softube Console 1 - Faderport - Monitor Station v2
User avatar
by hello people on Tue Jun 14, 2016 7:10 am
I can't get snap to grid working either. It will only snap to the measure, not in any of the divisions between measures. So if I want to snap half way between measures it just won't do it. The event just slides freely. I have snap to grid engaged, on bars and have used all ratios 1/16, 1/32 etc.

The simplest of simple DAW procedures and it won't snap half way between measures.

Seems like when you are zoomed in on an event it will only snap to the measure...the number. It will not snap anywhere between. But when zoomed out it will snap in between measures. But this is useless. I need to see what I am doing accurately zoomed in and I need it to snap.

Anyone know what to do?

User avatar
by niles on Tue Jun 14, 2016 11:04 am
hello people wroteI have snap to grid engaged, on bars and have used all ratios 1/16, 1/32 etc.
You should set snap to Quantize if you want it to snap to 1/16 or 1/32.

OS: Windows 10 Pro | HW: P9X79 • i7 3930K • 16GB • 3x EVO 860 • NVIDIA GT1030 (@WQHD) • RME AIO
User avatar
by hello people on Tue Jun 14, 2016 3:11 pm
I just want it to snap half way and quarter way between measures whether I am zoomed in or out of the event. What's the setting for that?

User avatar
by timothymonaghan on Tue May 30, 2017 7:23 pm
When I click the snap icon, that fixes the problem. It doesn't matter what's selected in the menu, if the snap icon isn't activated, the snap function won't work..

The icon is just to the right of the word "snap", and is blue when it's activated.

I have no idea why it sometimes gets de-activated. Bad mousing?
User avatar
by billykeys on Sun Jun 17, 2018 10:26 pm
timothymonaghan wroteWhen I click the snap icon, that fixes the problem. It doesn't matter what's selected in the menu, if the snap icon isn't activated, the snap function won't work..

The icon is just to the right of the word "snap", and is blue when it's activated.

I have no idea why it sometimes gets de-activated. Bad mousing?


What Timothy said! This worked for me. Thanks! Back to work :-)
User avatar
by slacknote on Mon Dec 28, 2020 1:33 am
bboerma wrote
niles wroteAre you sure you guys aren't fighting the Adaptive feature which changes the snap behavior based on the current zoom level.
In other words: The more you zoom in, the finer the snap resolution is.


Niles, you made my day! Thanks alot, that did the trick.


And five (5!) years later you made mine too!
User avatar
by rpdaple on Thu Jun 10, 2021 10:49 pm
Just had this issue. Somehow the setting under "snap" to the left of the snap to grid icon had been changed to bar instead of adaptive. Change that. Also make sure your Timebase is set to Bars/Quantize. That fixed it for me. Good luck.

18 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 9 guests