5 posts
Page 1 of 1
Got a weird behavior using the Korg NanoKontrol Studio: basically I set up the device, S1 recognize it and when I go in midi learn mode, it does see the knobs, faders and buttons, but I am not able to assign any VST control to it. I have installed the drivers, I have verified the midi messages and I have added successfully the device as midi controller.

I was successful in assigning macros, like for the play, record and stop buttons, but if I want to control any VST; it does not work. I move the control, it show on the top left corner in the control area, so I know it works. Then when I pick a vst and add it to a track, and right click on it to do a midi CC learn, I move the control but it does not get assigned. I twist the knob and nothing happen.

Am I missing something? The midi signals are working as expected; I see correctly the midi traffic with midi-ox, but Studio one seems to work only if I use macros for the application, but not for any of the VST.

Studio One 4 on Windows 10
Interfaces:
Scarlett 18i8 + iConnect Midi4+
Hardware:
- Yamaha Modx
- Korg Minilogue XD
- Roland JU-06A
- Roland Integra-7
- Roland Jupiter XM
- Modal Argon-8
- ipad Pro
Controllers:
- Arturia Keylab MK2
- Korg NanoKontrol Studio
User avatar
by cristofe on Tue Feb 11, 2020 11:55 am
I would post this question on the Korg forums..... ;)

https://soundcloud.com/cristofe-chabot/sets/main

PC'S: HP XW6000 Dual 3.2GHz Intel Xeon, 8GB RAM WinXP SP2 HP 6005 Pro AMD Athalon X2 B24 3.0Ghz, 4GB RAM Win8 Pro Dell Latitude E6410 Laptop Intel i5 2.67Ghz 8GB RAM Win7 Pro x64 Audio Interfaces: Terratec EWS88MT PCI (2), Audiobox 1818VSL USB & Firestudio 26x26 Firewire, Line 6 PodXT, Roland GS-10, NI Rig Kontrol 3

Monitors: Yamaha HS50M's DAW: S1 3.2.1 Pro

To add your software and hardware specs to your signature to make it easier for us to help you, click HERE.
User avatar
by FC-2 on Tue Feb 11, 2020 6:04 pm
Make sense; I started here because the NanoKontrol studio is doing this only with Studio one. It works fine with both Korg gadgets on ipad and on Cubase, with the same VST instruments :)

Studio One 4 on Windows 10
Interfaces:
Scarlett 18i8 + iConnect Midi4+
Hardware:
- Yamaha Modx
- Korg Minilogue XD
- Roland JU-06A
- Roland Integra-7
- Roland Jupiter XM
- Modal Argon-8
- ipad Pro
Controllers:
- Arturia Keylab MK2
- Korg NanoKontrol Studio
User avatar
by niles on Wed Feb 12, 2020 3:49 am
@FC-2 From the moment a message from an external device is mapped to an external device map it will be intercepted by the automation system (Control Link) before reaching the instrument track as MIDI data. So 3rd party instruments are unable to receive those messages for MIDI learning purposes. If you work with Control Link you'll have to assign the VST parameter to the mapped controller through Control Link.

OS: Windows 10 Pro | HW: P9X79 • i7 3930K • 16GB • 3x EVO 860 • AMD Radeon HD6450 (@WQHD) • RME AIO
User avatar
by FC-2 on Wed Feb 12, 2020 10:52 pm
niles wrote@FC-2 From the moment a message from an external device is mapped to an external device map it will be intercepted by the automation system (Control Link) before reaching the instrument track as MIDI data. So 3rd party instruments are unable to receive those messages for MIDI learning purposes. If you work with Control Link you'll have to assign the VST parameter to the mapped controller through Control Link.


I see, thanks for the clarification. I thought the assignment was done in the same way, independently if the VST was first party or 3rd party.

Studio One 4 on Windows 10
Interfaces:
Scarlett 18i8 + iConnect Midi4+
Hardware:
- Yamaha Modx
- Korg Minilogue XD
- Roland JU-06A
- Roland Integra-7
- Roland Jupiter XM
- Modal Argon-8
- ipad Pro
Controllers:
- Arturia Keylab MK2
- Korg NanoKontrol Studio

5 posts
Page 1 of 1

Who is online

Users browsing this forum: darrenporter1 and 12 guests