19 posts
Page 1 of 1
STEPS...

Create a number of events on a track.
Notice pressing left and right arrow on keyboard highlights the current position in blue.
Select the last event on the right, observe it's highlighted in blue.
Delete this event (or alternatively press right arrow).

Notice nothing to indicate where the current editing position is (i.e. cursor), if you went out, came back, you have absolutely no idea where you are. The current position has disappeared into another dimension. This makes for very confusing editing, because the position is lost. Poor design IMHO. Something should tell me where I am otherwise I end up reaching for the mouse (I don't want to do that).

If you do happen to remember what you last did, you press the left arrow and the last event will be displayed.

This is really irritating unless I'm missing something. The behaviour is the same with controllers like that atom when using left and right buttons.

Thanks

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by PreAl on Sun Dec 16, 2018 9:06 pm
The more I look at this, the more I see it as a workflow killer. It would be easy to trivialise but it's really bad, esp with Atom.. All they need to do is show a flashing cursor at the end of the last event (or beginning of track if there are no events in the track).

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by Jemusic on Sun Dec 16, 2018 11:52 pm
More information would help.
Where is the cursor before you deleted the last event? You have not really indicated that.
What I am seeing is if the cursor is in view nothing changes in terms of that if I delete events. i.e. it stays where it is! And if it is in view it stays in view.

I tend to create a loop around the whole area of interest. I have set number 1 to go to the left hand side of the loop and the number 2 to go to the right side of the loop. Beauty of this is simply press the number 1 and the cursor will always jump back to the start of your loop hence it will be seen. I used to do this in Cubase and Logic and I have just carried this over from them.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.



Specs i5-2500K 3.5 Ghz - 8 Gb RAM - Win 7 64 bit - ATI Radeon HD6900 Series - RME HDSP9632 - Midex 8 Midi interface - Faderport 8 and 2018- Atom Pad- iMac 2.5Ghz Core i5 - Sierra 10.12.6 - Focusrite Clarett 2 Pre & Scarlett 18i20. Studio One V3.5/4.1.2, Notion 6.5, Ableton Live 9, LaunchPad Pro
User avatar
by PreAl on Mon Dec 17, 2018 6:28 pm
Not sure if I can be more clear. Just don't use a mouse.

Highlight the last event in a track (far right), it's gonna be highlighted in blue.
Delete it (press delete button).

** Now look at the screen, there is no indicator of your position in the UI. ** The problem, there needs to be some indicator here. A flashing cursor or anything will do to help. Nothing is not good enough.

Press left arrow, the previous event is now highlighted. Now you know where you are again.

It is not the point of my thread to discuss workarounds or alternative workflow, the point is to show the deficiency in the UI here.

BTW don't use Mackie mode, don't use a mouse. Just use your qwerty keyboard or an atom.

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by Jemusic on Mon Dec 17, 2018 11:21 pm
A little more info would be good please. This way I want to set up exactly the same operations as you and observe what the cursor is up to.

1 How are you navigating the cursor position without the mouse. Can you specify from both QWERTY keyboard and ATOM.

2 Where is the cursor or is it in sight when you delete the last event on a track? Or are you implying it is off the page and not visible anymore when you delete that last event in a track.

Thx

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.



Specs i5-2500K 3.5 Ghz - 8 Gb RAM - Win 7 64 bit - ATI Radeon HD6900 Series - RME HDSP9632 - Midex 8 Midi interface - Faderport 8 and 2018- Atom Pad- iMac 2.5Ghz Core i5 - Sierra 10.12.6 - Focusrite Clarett 2 Pre & Scarlett 18i20. Studio One V3.5/4.1.2, Notion 6.5, Ableton Live 9, LaunchPad Pro
User avatar
by PreAl on Tue Dec 18, 2018 3:25 am
1) Create a few tracks with multiple events (at least 3 per track.
2) Only use arrow keys (nav left and right, up and down) and delete buttons from now on.
3) Select any track
4) Select the last event on the right (highlighted in blue).
5) Delete event
6) There is now no indicator of position until you press left arrow whereby another event will be highlighted

Sorry that's it. If you can't see what I'm saying please pass the baton to somebody else, I won't clarify further.

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by gottfriedbergmair on Tue Dec 18, 2018 6:17 am
No mouse. :( No keyboard. No controller. No discussion. :cry: Use Cortana! Ok this is a workaround. :)

Win 10 64 i7-7K 4x4,2 GHz 32GB, Presonus :D Studio One Pro 4.1 + Notion 6 + Studio 192 Mobile + Eris E8 + New Faderport 1; Mackie Big-Knob P, 402VLZ4; Akai MPD232, Some Arturia Equipment, Rode Mics, Roland VT-3, Zoom H5; SW: Arturia V Collection, Melodyne :D 4.2 STUDIO, iZotope RX
User avatar
by Jemusic on Tue Dec 18, 2018 6:55 am
I followed all your steps exactly. Whenever I delete the last event on any track the one to the left of it is always automatically selected. This happens for me whether the events are touching or separate as well. Also for me if I delete not the last event, but one in between two events, the one on the right is automatically selected.

Same behaviour for Windows or Mac and with ATOM as well for me.

What you mean by position? (you have yet to clarify) Cursor, or just events close by deleted events being selected or in your case not being selected..If you do mean cursor, my cursor stays in view with all these operations.

What you are seeing is not normal behaviour.. Only with your system it seems.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.



Specs i5-2500K 3.5 Ghz - 8 Gb RAM - Win 7 64 bit - ATI Radeon HD6900 Series - RME HDSP9632 - Midex 8 Midi interface - Faderport 8 and 2018- Atom Pad- iMac 2.5Ghz Core i5 - Sierra 10.12.6 - Focusrite Clarett 2 Pre & Scarlett 18i20. Studio One V3.5/4.1.2, Notion 6.5, Ableton Live 9, LaunchPad Pro
User avatar
by Lawrence on Tue Dec 18, 2018 8:11 am
There is now no indicator of position


There is, the time position display in the transport. If the play cursor is off of the screen or out of view, hit L to locate to and bring into view whatever is currently selected. In your editing steps I assume you don't intend to play the song from the end of that track where you just deleted a clip but if so, hit L to bring the cursor and selected event into view.

Hope that helps.
User avatar
by PreAl on Tue Dec 18, 2018 9:56 am
Lawrence wrote
There is now no indicator of position


There is, the time position display in the transport. If the play cursor is off of the screen or out of view, hit L to locate to and bring into view whatever is currently selected. In your editing steps I assume you don't intend to play the song from the end of that track where you just deleted a clip but if so, hit L to bring the cursor and selected event into view.

Hope that helps.


I'm not using any transport functions, I'm just creating and deleting events with qwerty keyboard, and navigating with arrow keys. Selecting the last event in the track means the last event in the track, thus the screen won't be out of view. I will then delete the event with the delete button and then there is no indicator of editing position in UI, until I press left arrow which will select the last event (the event before the deleted event).

That's it. Can't explain it any clearer.

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by bartbalint on Tue Dec 18, 2018 7:53 pm
I can highlight any event on any track using Atom or the keyboard. Highlighting the right most event is then deleted with the ‘delete’ key or with the ‘delete’ key on Atom. That event is gone, then the event immediately to the left of the deleted event is automatically highlighted and selected. The cursor stays exactly where it was before any delete. Seems to all work ok here. Unless I am missing something.

Studio One v4, Win10 1809, Focusrite Scarlett 18i20, Yamaha Motif6, MCU-Pro, Wacom pen tablet, GR55, Focusrite ASA one,
HPD-20, Mackie Big Knob, 8-)
User avatar
by PreAl on Thu Dec 20, 2018 8:26 am
Please check out my animated GIF.
BTW it does not matter where the white vertical line is, it's still the same behaviour.

Image

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by BobF on Thu Dec 20, 2018 9:36 am
Alex - I wish I could explain what's going on. I've tried this 9 ways from East here and I can't get it to do anything wrong.

Have you tried at 100% scaling? Maybe this is also related to your screen resolution.

Either way, I would submit a ticket on this as well.

-
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.

-------------------------------------------------------------
Studio One 4.1.1 / Notion 6 x64
Win10Pro x64 (1803) i7-6700 @3.8Ghz / 32G / 43" 4K | TASCAM US-16x08 / Event PS8 | FA06 / FaderPort 1 / LX61+
Waves Gold / Nomad IS3 / IKM Max / K11U
User avatar
by PreAl on Thu Dec 20, 2018 9:41 am
BobF wroteAlex - I wish I could explain what's going on. I've tried this 9 ways from East here and I can't get it to do anything wrong.

Have you tried at 100% scaling? Maybe this is also related to your screen resolution.

Either way, I would submit a ticket on this as well.


Yes text is at 100% scaling.
I'll try single monitor rather than dual monitor next.

Weird! I'll log a ticket soon.. thx.

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by PreAl on Thu Dec 20, 2018 10:29 am
OK it works with a brand new project. So it's project specific.
I guess there are more conditions to make this happen, further testing and steps are probably required. Right now I have no idea what they are.

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by PreAl on Thu Dec 20, 2018 10:40 am
Attached song file is here if anybody wants to try. Simply navigate from the first to last event with your arrow keys and delete.

Attachments
Bugged.song
(27.85 KiB) Downloaded 7 times

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by BobF on Thu Dec 20, 2018 10:43 am
Broken here with that song. I would submit with your ticket

-
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.

-------------------------------------------------------------
Studio One 4.1.1 / Notion 6 x64
Win10Pro x64 (1803) i7-6700 @3.8Ghz / 32G / 43" 4K | TASCAM US-16x08 / Event PS8 | FA06 / FaderPort 1 / LX61+
Waves Gold / Nomad IS3 / IKM Max / K11U
User avatar
by PreAl on Thu Dec 20, 2018 10:45 am
BobF wroteBroken here with that song. I would submit with your ticket


Excellent - thanks for that...

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.
User avatar
by PreAl on Thu Dec 20, 2018 10:50 am
Logged ticket request #481402.

Studio One Pro 4, Faderport 1, Atom, Focusrite Saffire Pro 40, Maschine Studio, Octapad SPD-30, Roland A300, Windows 10 Pro 64 bit.
EVGA Geforce 1070 (Nvidia drivers). A bigly amount of other gear.

19 posts
Page 1 of 1

Who is online

Users browsing this forum: martinmajor and 19 guests