8 posts
Page 1 of 1
Hi, hopefully someone can help me out here. I just bought EZdrummer 2, installed it, ran updates, and it's ready to go. I have a couple of other VST files loaded in the folder that Studio One 3 looks for VST files at and they load with no problem. I have the .dll file for EZdrummer 2 in that same folder however, Studio One 3 is not loading EZdrummer 2. I've looked in the "Effects" section where my other VST files show up at and I've looked under "Instruments" and it's not showing up there either. I'm totally out of ideas as to why it won't load when I have the VST file in the VST folder. I've tried closing out Studio One 3, restarting my computer, and neither worked.

I'm running Windows 8.1 btw.

Any help is greatly appreciated!

User avatar
by 5noteblues on Sat Jan 21, 2017 9:53 pm
You might have to tell St1/Options exactly which folder to find the EZD2 .dll I had the same problem with a different VST and it was resolved when I gave St1 a more specific path to the folder of the .dll. Seems some VST's don't need a clear path and others do.

If that doesn't work, then I 'd uninstall EZdrummer 2 and reinstall it. Make sure to keep track of where EZD2 is putting everything and don't check any boxes that asks if you'd like option for other DAWs like Ableton, Logic, etc.

Good luck.
User avatar
by ryanplylar on Sun Jan 22, 2017 10:02 am
That worked! I created a folder specifically for EZdrummer then dumped the .dll file into that folder and added that folder to the destination section in Studio One 3 and now it's showing up under the Instruments tab. Thanks for the advice 5noteblues!
User avatar
by christiannadeau on Wed May 01, 2019 4:41 pm
Hi Ryan , i have exactly the same problem ,can you please tel me exactly what you did to resolve this problem ,thanks in advance ,,,Christian n,

chris.n@bell.net" target="_blank
User avatar
by Tacman7 on Thu May 02, 2019 8:38 am
I would start a fresh thread. Get your specs in your signature first.

The better you can ask the question the easier the answer, sometimes you will see the answer if you take the time to write a detailed question. What you did, what's happening etc.

You basically need to install the product and remember where you put it then to look in VST locations S1 options and make sure that location is covered by an existing path or add a new one.

Forum Moderator.
Please add your specs to your SIGNATURE.
Search the STUDIO ONE 5 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.

Studio OnePro5 Melodyne Studio
Studio Computer - Nectar Impact LX25+
Win10 i7 7700k 16gb ram 1TB SSD AsusH270M-PLUS interface:StudioKonnekt 48
Kitchen Computer - Microkey Air Eris 3.5
Win10 Ryzen 5 3600 - Radeon RX 590 - 512GB SSD interface: Motu M2
User avatar
by bradch00 on Fri May 03, 2019 1:27 am
Open up EZD2 standalone application. Go to Help > Show Plug-in Path.
Add that path to your Studio One VST locations list or make sure it is already in the list.
Shutdown EZD2 (standalone)
Restart Studio One

2015 iMac 5K Retina (i7 4Ghz, 32GB RAM, 1TB Flash Drive)
Interface: Presonus Quantum, Black Lion (Red) Sparrow A/D
Control Surface: Faderport & Faderport 8
User avatar
by shanabit on Fri May 03, 2019 7:13 am
bradch00 wroteOpen up EZD2 standalone application. Go to Help > Show Plug-in Path.
Add that path to your Studio One VST locations list or make sure it is already in the list.
Shutdown EZD2 (standalone)
Restart Studio One

Winner Winner. :+1 :+1

StudioOnePro 5.4.1
Steinberg MR816X
OSX High Sierra 10.13.6
2010 MacPro Dual 2.4 Quad, 14 GB Ram
User avatar
by guadalupegarcia5 on Wed Sep 15, 2021 9:18 pm
awesome!!! It worked bro!! Thanks so much... have a great day!!! :+1

8 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 34 guests