19 posts
Page 1 of 1
I have Studio one v3 Professional.

I have the M-Audio Axiom 49 controller hooked up to my computer through USB

I run it with a Saffire pro 40 Firewire.

I can get the Axiom 49 to play and it makes sound but I can not get it to make use of the control knobs or sliders and expression wheels.

Can someone provide a link or a way to a PDF file that explains who to get this to work correctly?

I am working with AIR DB-33 and I can't get any of the sliders or faders to work with the plugin.

Thanks in advance for any help.

Intel Core i7-950 3.06GHz Quad Core
5Gb Memory
Windows 10 Professional x64 (latest updates installed)
Focusrite Saffire Pro 40 Interface
Presonus StudioOne 3 Professional (v3.5) (Latest updates installed)
User avatar
by matthewgorman on Tue Mar 15, 2016 12:17 pm
In my limited knowledge for this, I can confirm one element. To use the dual function of a keyboard like this, it needs to be added as a keyboard, and an external device also to get the function of the faders and pads

Matt

Lenovo ThinkServer TS140 Win 10 64bit, 8GB RAM, Intel Xeon
Lenovo Thinkpad E520, Windows 7 64bit, 8 GB RAM, Intel i5 Processor
StarTech EC13942 34mm Expresscard
S1Pro V2 , Melodyne Studio 4, Nomad Factory Studio Bundle, Waves , RM16, Studio 192, DP88, Faderport, Central Station Plus, Yamaha HS50 Monitors, Sceptre 6-8 Monitors, Temblor 10.
User avatar
by scottmoncrieff on Tue Mar 15, 2016 12:29 pm
Does this help ?

Image

THE INTRANCER- Digital 2D & 3D GUI / Music Artist |- Full Orchestral -Trance - Ambient - Film Scores 27 on S-Cloud 7000+genuine plays | 16 on S-Click | Studio One 3 Concept Re-Designs - Sample One XT | Reason X | S-O-3 Pro | Reaktor 6.0 | Reason 7 | C4D | CS6 |Win 7 64 Bit-Intel I7 920@3.57GHz,Focusrite Pro 14, ATH M50's, Casio XW P1&G1 Producer 20+ years - FOH - UK Stadium / Festivals) >>Studio One 3D GUI's<<
User avatar
by tridyed on Tue Mar 15, 2016 2:57 pm
I think it's a combo between both answers. I found a video about Studio One v2 and the axiom pro where it did set up two things (a KB and a Controller) but I still can't get V3 to let me set up the controls yet. IT will play sounds but will not assign control sliders or knowbs yet.

Any one else that has some info please chime in, and thanks for the hints so far, they are leading down the correct path.... still trying to find the magic ending

Intel Core i7-950 3.06GHz Quad Core
5Gb Memory
Windows 10 Professional x64 (latest updates installed)
Focusrite Saffire Pro 40 Interface
Presonus StudioOne 3 Professional (v3.5) (Latest updates installed)
User avatar
by matthewgorman on Tue Mar 15, 2016 3:18 pm
I am working with AIR DB-33 and I can't get any of the sliders or faders to work with the plugin.


These may need to be mapped via control link. With the plug/instrument open, you will see default control listed at the top right of the gui. There is also an edit botton, that will expand the gui to show control link editing. Move a parameter on the plug, then move the control you want to map to that parameter, and you will see them listed side by side. Hit the link button between them, and that will map it.

Matt

Lenovo ThinkServer TS140 Win 10 64bit, 8GB RAM, Intel Xeon
Lenovo Thinkpad E520, Windows 7 64bit, 8 GB RAM, Intel i5 Processor
StarTech EC13942 34mm Expresscard
S1Pro V2 , Melodyne Studio 4, Nomad Factory Studio Bundle, Waves , RM16, Studio 192, DP88, Faderport, Central Station Plus, Yamaha HS50 Monitors, Sceptre 6-8 Monitors, Temblor 10.
User avatar
by niles on Tue Mar 15, 2016 3:33 pm
First question: Do you see activity in the MIDI monitor when turning knobs on the Axiom?
Second question: Do you want to use the external controls (CC's) from the Axiom as automation data or MIDI data to drive VST's connected to Instrument tracks?
Third question: Did you learned any of the external controls through the External Device map?

OS: Windows 10 Pro | HW: P9X79 • i7 3930K • 16GB • HD6450 (WQHD) • RME AIO
User avatar
by tridyed on Tue Mar 15, 2016 4:40 pm
niles wroteFirst question: Do you see activity in the MIDI monitor when turning knobs on the Axiom?
Second question: Do you want to use the external controls (CC's) from the Axiom as automation data or MIDI data to drive VST's connected to Instrument tracks?
Third question: Did you learned any of the external controls through the External Device map?


First question: Do you see activity in the MIDI monitor when turning knobs on the Axiom?
Yes, I am getting midi into the DAW from those sliders or knobs

Second question: Do you want to use the external controls (CC's) from the Axiom as automation data or MIDI data to drive VST's connected to Instrument tracks?
Yes, trying to get drawbars and rotor speed to work off the controller for DB-33

Third question: Did you learned any of the external controls through the External Device
Yes, It wont learn when I right click and select learn CC and move the faders or the drawbars on the plugin

Intel Core i7-950 3.06GHz Quad Core
5Gb Memory
Windows 10 Professional x64 (latest updates installed)
Focusrite Saffire Pro 40 Interface
Presonus StudioOne 3 Professional (v3.5) (Latest updates installed)
User avatar
by niles on Tue Mar 15, 2016 4:55 pm
tridyed wroteThird question: Did you learned any of the external controls through the External Device
Yes, It wont learn when I right click and select learn CC and move the faders or the drawbars on the plugin
As soon as you learn the CC's from your controller to Studio One's External Device map, all CC data will be picked up by the Control Link system and not passed through to VST's connected to the Instrument tracks as MIDI CC data. So if you want CC's to control VST's from Instrument Tracks as MIDI CC data, you should not learn those to Studio One's External Device map.

OS: Windows 10 Pro | HW: P9X79 • i7 3930K • 16GB • HD6450 (WQHD) • RME AIO
User avatar
by rosssantos on Tue Aug 13, 2019 3:15 pm
I too have an Axiom, AxiomPro61, it worked wonderful with PT, but with SO4.52 I can't control the Rotor speed. I am using a Presence XT Organ with the Rotor plug, I can see the mod wheel values change just fine, but cannot use Control Link, it is never displayed as an option. I also do not see any of my control surface for the controller and there is no MIDI Learn function available.

So I added a new keyboard and voila, now I can add my controls with MIDI Learn. I contacted support and they say this isn't necessary to do. But without doing that, I can't link a control surface button, knob, fader or pad to a specific parameter in Rotor.

I'm a NUBE in SO, so obviously I'm missing something crucial. The odd thing is that in other Presence XT sounds, the mod wheel performs functions as expected, like on the Rhodes pianos, it introduces tremolo.

Does anyone have a solution?
User avatar
by Jemusic on Tue Aug 13, 2019 5:37 pm
There was an issue with some recent updates that required your external instruments to be removed and replaced with new ones again. It's not a bad thing to do. If you have any trouble with external instruments just remove and replace.

Please add your specs to your SIGNATURE.
Search the STUDIO ONE 4 ONLINE MANUAL. Access your MY.PRESONUS account.
OVERVIEW of how to get your issue fixed or the steps to create a SUPPORT TICKET.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.



Specs i5-2500K 3.5 Ghz - 8 Gb RAM - Win 7 64 bit - ATI Radeon HD6900 Series - RME HDSP9632 - Midex 8 Midi interface - Faderport 8 and 2018- Atom Pad- iMac 2.5Ghz Core i5 - Sierra 10.12.6 - Focusrite Clarett 2 Pre & Scarlett 18i20. Studio One V4.5, Notion 6.5, Ableton Live 10 Suite, LaunchPad Pro
User avatar
by rosssantos on Tue Aug 13, 2019 5:59 pm
Thanks Jemusic... I can do that and see if it makes any difference

update: Support had me go into the macro editor on the channel and set the mod wheel and Rotor properties I wanted it to affect. Interestingly, in the editor I can now move the button (increase/decrease) and Rotor responds, but using the mod wheel has no affect except for increasing/decreasing the value on that button - it's like it sees it but it doesn't respond. Stumped...
User avatar
by rosssantos on Wed Aug 14, 2019 8:43 am
Support got back with me and said that my new issue is a bug and has been forwarded to QA/DEV - sigh
User avatar
by roland1 on Wed Aug 14, 2019 10:52 am
I think a lot of people with bug issues get frustrated by the process of convincing others that there's a problem and may just wind up dropping the issue rather than following though.

Glad you kept at it and didn't just accept defeat. Now let's see what the company does... :)

I use: Studio One "Bug" Pro v4.51 & v3.56 on an i7 7700 win10 PC w16GB RAM and on a Mac Pro Tower (Sierra) w/RME & Focusrite interfaces.

When not loitering here, I can be found at: http://RolandK.ca

Attention all shoppers: deception and commerce are old friends. Ask questions; don't just nod and agree as expected.
[Unless it's "On sale" with a warning to "Hurry. Act now!" so you can also get a "FREE" [whatever] — what an awesome deal!]
User avatar
by rosssantos on Wed Aug 14, 2019 11:00 am
Roland1 - I understand the bug process quite well, I've developed software for over 40 years. When it comes to something not working, I'm like a dog with a bone :)
User avatar
by roland1 on Wed Aug 14, 2019 11:03 am
rosssantos wroteRoland1 - I understand the bug process quite well, I've developed software for over 40 years. When it comes to something not working, I'm like a dog with a bone :)


Can you fix the Scratch Pad for me? :D

I use: Studio One "Bug" Pro v4.51 & v3.56 on an i7 7700 win10 PC w16GB RAM and on a Mac Pro Tower (Sierra) w/RME & Focusrite interfaces.

When not loitering here, I can be found at: http://RolandK.ca

Attention all shoppers: deception and commerce are old friends. Ask questions; don't just nod and agree as expected.
[Unless it's "On sale" with a warning to "Hurry. Act now!" so you can also get a "FREE" [whatever] — what an awesome deal!]
User avatar
by rosssantos on Wed Aug 14, 2019 11:03 am
ok, so support told me to ask you all what you use as a Organ plugin that has a leslie that actually can be controlled by the mod wheel. I've used db33 when I was on PT, wondering what everyone else uses.
User avatar
by roland1 on Wed Aug 14, 2019 11:25 am
Korg Legacy M1 should have it.
Ni B3 or one of the various NI organ patches should.
Probably FM8 / Reaktor

I'm not even thinking about it much. There should be a dozen.

I use: Studio One "Bug" Pro v4.51 & v3.56 on an i7 7700 win10 PC w16GB RAM and on a Mac Pro Tower (Sierra) w/RME & Focusrite interfaces.

When not loitering here, I can be found at: http://RolandK.ca

Attention all shoppers: deception and commerce are old friends. Ask questions; don't just nod and agree as expected.
[Unless it's "On sale" with a warning to "Hurry. Act now!" so you can also get a "FREE" [whatever] — what an awesome deal!]
User avatar
by rosssantos on Wed Aug 14, 2019 12:07 pm
Thanks I will check them out!
User avatar
by rosssantos on Wed Aug 14, 2019 3:41 pm
I tried Blue3 and love it and it works as I expected. Will be purchasing it.

19 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 6 guests