Requests or concerns about the forum itself.
Technical Support requests should be logged directly at http://support.presonus.com
5 posts
Page 1 of 1
In my forum profile under the avatar section it says "Please go to my.presonus com to update your account settings". I did this and a photo now appears there. But it does not appear on my forum posts, :?: :?:

My songs

Intel i9 9940X @ 3.3GHz, 14 cores, 32GB RAM.
OS & Programs drive: 1TB SSD
Data drives: 1 x 1TB SSD drive, plus extra 1TB HDD drive
Windows 10 Pro 64 bit
Studio One 64 bit. Version: 4.6.1.55987
Cakewalk by BandLab
1 Lava Lamp
User avatar
by jBranam on Wed Jul 02, 2014 2:24 am
top right banner on site here has your pic. place mouse over it and it will drop a menu down. under my account... upload a new pic from there. but also at the bottom of this forum there is a delete cookies link. click it and refresh. you will again have to say you are a human and all should be well after that. cheers


“bakers please step away from the tarts”


Ryzen 5 1600 : Asrock AB350M Pro4 : 32Gb 2400 RAM : Win10 64bit
Macbook Pro 13 : 10th Gen Quad i5 : 512Gb SSD and 1Tb Glyph Atom SSD : 16Gb 3733 RAM : Catalina 10.15.5
iPad Air 3rd Gen : 64Gb : A12 Bionic : 10.5 inch
Presonus 192 Mobile : Audient iD4
Ultrasone 900 Pro : Blue Lola : Blue Mix-Fi : AKG 240 Studio
Samson Resolv 50a : Ik Multimedia iLoud


Knot Hardly Productions
¯\_ { ͡• ͜ʖ ͡•} _/¯
User avatar
by Kiwicomposer on Wed Jul 02, 2014 2:34 am
Check out the New Forums 101 area: viewforum.php?f=217

And in particular te advice about the Avatar: viewtopic.php?f=217&t=132

Steve Currington
Wellington, New Zealand

Presonus Audiobox1818vsl, Presonus Audiobox USB, Focusrite Liquid Saffire 56, Presonus Faderport, Presonus Monitor Station v2, M-Audio Axiom Pro 49 keyboard, KMI QuNeo & QuNexus, sundry other external FX hardware, mics, plugins & instruments.
Studio One v2.6.3, Sibelius v7.x, Notion v5.x, Progression v3.x, Melodyne Editor v2.1.2, Logic 9.x
iMac's & MacBookAir all running OSX Mavericks 10.9.5

To add your software and hardware specs to your signature to make it easier for us to help you, click HERE.
User avatar
by db on Wed Jul 02, 2014 12:35 pm
jBranam wrotetop right banner on site here has your pic. place mouse over it and it will drop a menu down. under my account... upload a new pic from there. but also at the bottom of this forum there is a delete cookies link. click it and refresh. you will again have to say you are a human and all should be well after that. cheers


That did the trick for me. Was pretty stuck before. ;)

House | Dubstep by Thedmncproject

i7 920 | W8.1 x64 | 12GB RAM | Samson | Studio One Pro v2 | Echo Audio Fire 4 | Nvidia GTX 480
User avatar
by billtilton on Mon Jul 27, 2020 4:04 pm
I've tried everything suggested but nothing happens. Please help!

5 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest