Requests or concerns about the forum itself.
Technical Support requests should be logged directly at http://support.presonus.com
3 posts
Page 1 of 1
I couldn't find a direct link to the forum anywhere on the site, having to google for it.
I thought it'd be under Support or Community, but it's not. Where in the navigation can I find it?
Is it hidden on purpose?

Fernando Lins
Electronic music @ [url]loqvst.com[/url]

Studio One 3.5.1 Professional
AudioBox 1818 VSL - latest driver/firmware
Windows 10 64-bit - latest
Intel Core i5-3470 @ 3.2GHz
16GB RAM
Geforce GTX 950
User avatar
by jpettit on Wed Dec 06, 2017 10:56 am
Yes, the Forum is Community run and not manned by PreSonus.
They do occasionally pop in.

Please add your specs to your SIGNATURE.
OVERVIEW of how to get your issue fixed.
Search the ONLINE MANUAL, Create a SUPPORT TICKET and or Post Issue.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.


My Website, Free Studio One Advance Training
SPECS:Win 10 64-bit, 12 Core i7: 32Gb DDR4 ram, 40" 4K monitor, StudioLive 24, Quantum, Faderport16, Central Station Plus, Sceptre 6,Temblor T10, Eris 4.5, HP60, Studio One Pro 4.0, Reaper 5.9, Sonar Platinum
User avatar
by Skip Jones on Wed Dec 06, 2017 12:41 pm
Navigate to it via Google or whatever and then bookmark it. Done, you created your own link.

Windows 10 X 64 : AMD Phenom II X 4 945
ATI Radeon 5450 / 512 RAM
8GB RAM / 1T SATA

Mac Mini (Late 2014)

Faderport and Faderport 8
Yamaha S-08
Fishman TriplePlay
Logidy Controller

Assorted PreSonus Gear

IPlease add your specs to your SIGNATURE.
OVERVIEW of how to get your issue fixed.
Search the ONLINE MANUAL, Create a SUPPORT TICKET and/or Post Issue.
Needs to include: 1) One Sentence Description 2) Expected Results 3) Actual Results 4) Steps to Reproduce.

3 posts
Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest