image description


route instruments from Kontakt to the mixer?
  Forum Index » How do I (You fill in the blank)? 
Author
Message
aaron nolan
Prenoob

Joined: 06/10/2012 19:40:50
Messages: 12
Offline

Hi

I'm currently using one instant of kontakt 5 , it has 8 instruments loaded, each one for a selected midi track. The main output appears in the mixer... I want all the instruments to be routed individually in order to send them to different filters.

How do I route all these instruments individually?

Thanks in advance
aaron nolan
Prenoob

Joined: 06/10/2012 19:40:50
Messages: 12
Offline

I figured how to do it...but...

When I assign the instruments to different outputs , the sound quality changes, it become more flat, as if it has been placed in a room (it sounds with reverb)...dunno...any explanation?

I would be very appreciative for your replies

This message was edited 1 time. Last update was at 12/04/2013 13:31:09

ocejanic
Prenoob

Joined: 12/04/2013 14:47:51
Messages: 6
Offline

Have you routed them (within Kontakt) to the Aux Channels, and are these perhaps also "loaded" with any effect signal?

This message was edited 1 time. Last update was at 12/04/2013 16:04:04

aaron nolan
Prenoob

Joined: 06/10/2012 19:40:50
Messages: 12
Offline

Have you routed them (within Kontakt) to the Aux Channels, and are these perhaps also "loaded" with any effect signal?


Thanks ocejanic

No, the Aux channels are inactive. but their outputs are active.... The sound that comes out from the Kt.aux outputs is normal (no prob). And I can monitor them in the mixer by seeing one single channel output from each instrument (it has 2 signal bars in one single channel). but when it comes to the Kt. unassigned outputs , they are routed as pairs in the mixer (each instrument has 2 channels in the mixer of studio one), and the sound is a bit different. (it's not like a stereo channel, it's like a double mono forming one stereo, if I turn off one of them, the sound comes out weak,and one sided,...)
and each one of them has 1 signal bar, 1signal bar in each = 2 bars. whereas the Aux out puts (Kt.aux) have 2 signal bars in one channel...

I want to make it simple and sound natural , I don't want the sound to be different, and I want to control the instruments from one channel at a time (not in pairs)...

Edit:
In the Channel output configuration there are two types of output plugins:

1- Kt.aux (1,2....until aux4)
2- Kt. unassigned (1.....54)

the problem is from the Kt. unassigned.


PS: the Aux channels are inactive, but their outputs are active in the first 4 St channels. I don't know how to explain it, I don't know if you understood what I mean. It's a bit complicated. I will explain again if you did not understand.

This message was edited 4 times. Last update was at 13/04/2013 10:57:09

aaron nolan
Prenoob

Joined: 06/10/2012 19:40:50
Messages: 12
Offline

The sound problem has been resolved; I panned each channel . the issue that is still bothering me is that there are two channels for one instrument. and I have to pan each one of them to get the same stereo sound that comes out from the Kt.aux outputs.

any idea? Is there a way to merge these two channels in one single stereo output (in S1 mixer)?


And I also want to ask where can I post a thread (In which section on this web) concerning questions about filters,Pro EQ, etc....

This message was edited 2 times. Last update was at 13/04/2013 11:26:08

ocejanic
Prenoob

Joined: 12/04/2013 14:47:51
Messages: 6
Offline

O.k., I understood your workaround with to separate mono channels for one Kontak instrument.

I suggest the following (for I had to find out about routing Kontakt 5 and Studio One 2.5 these days..)

1.
Start Kontakt 5 Standalone. Don't load any instruments yet. In the output section of the Kontakt window, check which channels you have as a default. There should be at least one Stereo Channel and 4 aux channels, also stereo.

2. Add as many channels as you need by clicking on the "Add channels" tab. In the pop-up window, set the number of channels you need (the "quantity" field). The "Number of channels"-field below this is a bit misleading, as it does not refer to the number of channels you set in the quantity field, but to the actual audio channels per channel: If you set it to "1", this means you are creating mono channels. So set this to "2", creating stereo channels. Leave the "soundcard/host output" field to "not connected" for now.
Click ok.
Now you should see your stereo channels appearing in the output section left to the aux channels (BTW the aux channels cannot be deleted).

3. Under each fader,you see a small button (Channel configuration tab). It should look like this: -/-
If there are any numbers, click on the button, and in the pop-up window click on each of the two physical out entries, changing them to "not connected" (scroll down the list). (BTW the options you get there are the actual physical outs of your connected audio interface). Click ok.

4. Save this configuration as a default by clicking on the "Presets/Bach configuration" tab above the faders. Select "Save current output section state as default for..." --> "VST plugin. This way, every time you open Kontakt as a plugin in Studio One, it will start up with this output configuration. You can always change this later.

5. Close Kontakt and start Studio One. Add a Track with Kontakt. Now you should have your pre-definded output setting from the start.

6. Click the Channel Configuration tab under the faders in Kontakt and assign the two outputs for each channel by starting with the first from the list (should be "Kt Stereo 1 [1] and Kt Stereo 1 [2]", etc. going down the list channel by channel.

Now whenever you assign or change any output setting of Kontakt after it has been loaded as a plug-in, there is a pop-up window tellng you to close and re-open Kontakt to make the change effective in Studio one. Just click ok, change all channels one by one.

Make this new setting permament by again clickiing on "Save current output section state as default for..." --> "VST plugin.

Now throw Kontakt out of Studio One by deleting the Kontakt entry in the MIXER section ( left, under "instrument". Just right-click and delete)
Now reopen Kontakt again by adding a Kontakt track. The output assignment should now be the default.


7. Add instruments to Kontakt 5, as many as you have defined channels. Mind that by default Kontakt assigns every instrument to the same output channel St 1! Although it automatically assigns different MIDI channels...
So now you have to change the default output of each instrument in the Kontakt window, right above the field wheree you change the MIDI channel of the instrument. In the list that pops up when you click on the output tab (right under the instruments name), you cann now chose the outputs you have formerly defined.

8. Now if you check in the Studio One Mixer, you will still only see one channel (Kt st 1). To make the other Kontakt channels visible, click on the little white triangle left of the "Kontakt 5" entry in the instruments column of the mixer (left of the fader section in Studio One). Click on the second entry from above (in German it says "Einblenden", so it must be something like "show").
A list opens up with all the Kontakt channels you have defined before. You can see that the only entry that has a blue tag is the one you already see. By tagging the others, you make them visible in the mixer section. Mind that there is a tiny white square to the right of the entries, with which you can scroll down the channel list.

9. Add as many instrument channels in the Studio One arrange/track window as you have instruments in Kontakt, Assign Kontakt as theinput and the appropriate MIDI channel.

Now you should be able to play each Kontakt instrument by activating the referring track in studio one, and you should see the referring signal meter moving in the mixer.


Tell me if it worked for you.

Cheers,


Jan



This message was edited 1 time. Last update was at 13/04/2013 19:11:32

aaron nolan
Prenoob

Joined: 06/10/2012 19:40:50
Messages: 12
Offline

Jan

Thanks very much, I really appreciate your explanation. It worked finally. I had a large orchestral template, almost 180 instruments, I thought that I have to rebuild my template from scratch because I haven't had the batch configuration set from the beginning, but the new settings was applied directly to my template.
And also, there's a new feature in studio one 2.5 that automatically arranges the input instruments to the output midi channels. you don't have to connect them individually one by one.

I thank God Jan

This message was edited 2 times. Last update was at 14/04/2013 15:15:50

 
Forum Index » How do I (You fill in the blank)?
Go to: